Merge branch 'wip'
This commit is contained in:
commit
14564ce6cc
10 changed files with 57 additions and 25 deletions
18
debian/changelog
vendored
18
debian/changelog
vendored
|
@ -1,3 +1,21 @@
|
|||
midori (0.4.6-1) UNRELEASED; urgency=low
|
||||
|
||||
* New upstream release.
|
||||
* Apply patch from Colin Watson to improve conffile handling, using new
|
||||
debhelper features. closes: #659773
|
||||
* debian/control:
|
||||
- update standards version to 3.9.3.
|
||||
- update homepage address.
|
||||
* debian/midori.maintscript:
|
||||
- handle the /etc/xdg/midori/extensions/libadblock.so removal there.
|
||||
closes: #660303
|
||||
* debian/patches:
|
||||
- force-ssl-cert-verification added, set ssl-strict to TRUE so connections
|
||||
are not done if the ssl certificate can't be trusted.
|
||||
* debian/compat bumped to 9.
|
||||
|
||||
-- Yves-Alexis Perez <corsac@debian.org> Tue, 15 May 2012 23:31:12 +0200
|
||||
|
||||
midori (0.4.3+dfsg-0.1) unstable; urgency=low
|
||||
|
||||
* Non-maintainer upload
|
||||
|
|
2
debian/compat
vendored
2
debian/compat
vendored
|
@ -1 +1 @@
|
|||
7
|
||||
9
|
||||
|
|
7
debian/control
vendored
7
debian/control
vendored
|
@ -3,7 +3,7 @@ Section: web
|
|||
Priority: optional
|
||||
Maintainer: Ryan Niebur <ryan@debian.org>
|
||||
Uploaders: Yves-Alexis Perez <corsac@debian.org>
|
||||
Build-Depends: debhelper (>= 7.0.50),
|
||||
Build-Depends: debhelper (>= 8.1.0~),
|
||||
lsb-release,
|
||||
libgtk2.0-dev (>= 2.10),
|
||||
libglib2.0-dev,
|
||||
|
@ -31,13 +31,14 @@ Build-Depends: debhelper (>= 7.0.50),
|
|||
Build-Conflicts: gtk-doc-tools,
|
||||
libgtksourceview2.0-dev (>= 2.0),
|
||||
libhildon-1-dev
|
||||
Standards-Version: 3.9.2
|
||||
Homepage: http://www.twotoasts.de/index.php?/pages/midori_summary.html
|
||||
Standards-Version: 3.9.3
|
||||
Homepage: http://www.midori-browser.org
|
||||
Vcs-Git: git://git.debian.org/collab-maint/midori.git
|
||||
Vcs-Browser: http://git.debian.org/?p=collab-maint/midori.git;a=summary
|
||||
|
||||
Package: midori
|
||||
Architecture: any
|
||||
Pre-Depends: ${misc:Pre-Depends}
|
||||
Depends: ${shlibs:Depends}, ${misc:Depends}, dbus-x11
|
||||
Recommends: gnome-icon-theme
|
||||
Provides: www-browser
|
||||
|
|
2
debian/midori.maintscript
vendored
Normal file
2
debian/midori.maintscript
vendored
Normal file
|
@ -0,0 +1,2 @@
|
|||
mv_conffile /etc/xdg/midori/extensions/libadblock.so/config /etc/xdg/midori/extensions/adblock/config 0.4.1-2
|
||||
rm_conffile /etc/xdg/midori/extensions/libadblock.so 0.4.1-2
|
5
debian/midori.postinst.base
vendored
5
debian/midori.postinst.base
vendored
|
@ -9,10 +9,5 @@ case "$1" in
|
|||
x-www-browser.1.gz /usr/share/man/man1/midori.1.gz
|
||||
;;
|
||||
esac
|
||||
dpkg-maintscript-helper mv_conffile \
|
||||
/etc/xdg/midori/extensions/libadblock.so/config \
|
||||
/etc/xdg/midori/extensions/adblock/config \
|
||||
0.4.1-2 midori -- "$@"
|
||||
rmdir /etc/xdg/midori/extensions/libadblock.so || true
|
||||
#DEBHELPER#
|
||||
exit 0
|
||||
|
|
8
debian/midori.postrm
vendored
8
debian/midori.postrm
vendored
|
@ -1,8 +0,0 @@
|
|||
#!/bin/sh
|
||||
set -e
|
||||
dpkg-maintscript-helper mv_conffile \
|
||||
/etc/xdg/midori/extensions/libadblock.so/config \
|
||||
/etc/xdg/midori/extensions/adblock/config \
|
||||
0.4.1-2 midori -- "$@"
|
||||
#DEBHELPER#
|
||||
exit 0
|
8
debian/midori.preinst
vendored
8
debian/midori.preinst
vendored
|
@ -1,8 +0,0 @@
|
|||
#!/bin/sh
|
||||
set -e
|
||||
dpkg-maintscript-helper mv_conffile \
|
||||
/etc/xdg/midori/extensions/libadblock.so/config \
|
||||
/etc/xdg/midori/extensions/adblock/config \
|
||||
0.4.1-2 midori -- "$@"
|
||||
#DEBHELPER#
|
||||
exit 0
|
22
debian/patches/force-ssl-cert-verification.patch
vendored
Normal file
22
debian/patches/force-ssl-cert-verification.patch
vendored
Normal file
|
@ -0,0 +1,22 @@
|
|||
diff --git a/midori/main.c b/midori/main.c
|
||||
index 2ec5599..af3cc71 100644
|
||||
--- a/midori/main.c
|
||||
+++ b/midori/main.c
|
||||
@@ -1019,7 +1019,7 @@ midori_load_soup_session (gpointer settings)
|
||||
#if defined (HAVE_LIBSOUP_2_37_1)
|
||||
g_object_set (session,
|
||||
"ssl-use-system-ca-file", TRUE,
|
||||
- "ssl-strict", FALSE,
|
||||
+ "ssl-strict", TRUE,
|
||||
NULL);
|
||||
#elif defined (HAVE_LIBSOUP_2_29_91)
|
||||
const gchar* certificate_files[] =
|
||||
@@ -1038,7 +1038,7 @@ midori_load_soup_session (gpointer settings)
|
||||
{
|
||||
g_object_set (session,
|
||||
"ssl-ca-file", certificate_files[i],
|
||||
- "ssl-strict", FALSE,
|
||||
+ "ssl-strict", TRUE,
|
||||
NULL);
|
||||
break;
|
||||
}
|
1
debian/patches/series
vendored
1
debian/patches/series
vendored
|
@ -1 +1,2 @@
|
|||
add-debian-searches
|
||||
force-ssl-cert-verification.patch
|
||||
|
|
9
debian/rules
vendored
9
debian/rules
vendored
|
@ -40,6 +40,15 @@ get-orig-source:
|
|||
|
||||
WAF=WAFDIR=waf-modules ./waf-unpacked
|
||||
|
||||
#$(WAF): waf
|
||||
# # rebuild the waf script
|
||||
# sed < waf -e '1,/^#==>$$/ d' -e '/^#<==$$/ d' | tr -d '\n' | sed -e 's/.//' -e 's/#[*]/\n/g' -e 's/#%/\r/g' > waf.orig.tar.bz2
|
||||
# (sed -n < waf -e '1,/^#==>$$/ p'; echo REPLACED BY ENCODED TAR.BZ2; sed -n < waf -e '/^#<==$$/ p') > waf.hdr
|
||||
# (sed -n < waf.hdr -e '1,/^#==>$$/ p'; printf '#'; perl -pe < waf.orig.tar.bz2 's/\n/#*/g; s/\r/#%/g;'; echo; sed -n < waf.hdr -e '/^#<==$$/ p') > waf.regen
|
||||
# chmod 755 waf.regen
|
||||
# # ensure both scripts are the same
|
||||
# cmp waf waf.regen && (rm waf.hdr waf.orig.tar.bz2)
|
||||
|
||||
debian/presubj: debian/presubj.in
|
||||
@echo "presubj parameters:"
|
||||
@echo "Replacing %LIBWEBKIT_PKG% with $(LIBWEBKIT_PKG)"
|
||||
|
|
Loading…
Reference in a new issue