* debian/patches:
- 0001-Fix-for-Bug-819688 added, correctly restore tab panel when needed.
This commit is contained in:
parent
b7fae5ebe9
commit
1b3bda9a17
3 changed files with 50 additions and 0 deletions
7
debian/changelog
vendored
7
debian/changelog
vendored
|
@ -1,3 +1,10 @@
|
||||||
|
midori (0.4.0-2) UNRELEASED; urgency=low
|
||||||
|
|
||||||
|
* debian/patches:
|
||||||
|
- 0001-Fix-for-Bug-819688 added, correctly restore tab panel when needed.
|
||||||
|
|
||||||
|
-- Yves-Alexis Perez <corsac@debian.org> Mon, 05 Sep 2011 22:42:34 +0200
|
||||||
|
|
||||||
midori (0.4.0-1) unstable; urgency=low
|
midori (0.4.0-1) unstable; urgency=low
|
||||||
|
|
||||||
* New upstream release.
|
* New upstream release.
|
||||||
|
|
42
debian/patches/0001-Fix-for-Bug-819688.patch
vendored
Normal file
42
debian/patches/0001-Fix-for-Bug-819688.patch
vendored
Normal file
|
@ -0,0 +1,42 @@
|
||||||
|
From b81370bd81f782836bbabdcca4cf7cb219ed53cf Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Andr=C3=A9=20St=C3=B6sel?= <andre@stoesel.de>
|
||||||
|
Date: Mon, 5 Sep 2011 18:02:42 +0200
|
||||||
|
Subject: [PATCH] Fix for Bug #819688
|
||||||
|
|
||||||
|
---
|
||||||
|
midori/midori-panel.c | 5 ++++-
|
||||||
|
1 files changed, 4 insertions(+), 1 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/midori/midori-panel.c b/midori/midori-panel.c
|
||||||
|
index a7abc81..5d6dad0 100644
|
||||||
|
--- a/midori/midori-panel.c
|
||||||
|
+++ b/midori/midori-panel.c
|
||||||
|
@@ -13,6 +13,8 @@
|
||||||
|
|
||||||
|
#include "midori-view.h"
|
||||||
|
|
||||||
|
+#include "midori-browser.h"
|
||||||
|
+
|
||||||
|
#include "marshal.h"
|
||||||
|
#include "sokoke.h"
|
||||||
|
|
||||||
|
@@ -588,6 +590,7 @@ static void
|
||||||
|
midori_panel_viewable_destroy_cb (GtkWidget* viewable,
|
||||||
|
MidoriPanel* panel)
|
||||||
|
{
|
||||||
|
+ MidoriBrowser* browser = midori_browser_get_for_widget ( GTK_WIDGET (panel));
|
||||||
|
gint n_pages;
|
||||||
|
gchar* action_name;
|
||||||
|
GtkAction* action;
|
||||||
|
@@ -601,7 +604,7 @@ midori_panel_viewable_destroy_cb (GtkWidget* viewable,
|
||||||
|
viewable, midori_panel_viewable_destroy_cb, panel);
|
||||||
|
|
||||||
|
n_pages = midori_panel_get_n_pages (panel);
|
||||||
|
- if (n_pages > 0)
|
||||||
|
+ if (n_pages > 0 && browser && !g_object_get_data (G_OBJECT (browser), "midori-browser-destroyed"))
|
||||||
|
midori_panel_set_current_page (panel, (n_pages-1 > i) ? i : n_pages - 1);
|
||||||
|
|
||||||
|
action_name = g_strconcat ("PanelPage",
|
||||||
|
--
|
||||||
|
1.7.6.1
|
||||||
|
|
1
debian/patches/series
vendored
1
debian/patches/series
vendored
|
@ -1 +1,2 @@
|
||||||
add-debian-searches
|
add-debian-searches
|
||||||
|
0001-Fix-for-Bug-819688.patch
|
||||||
|
|
Loading…
Reference in a new issue