refreshed patches
This commit is contained in:
parent
5aa73dea25
commit
3c395daddb
3 changed files with 24 additions and 15 deletions
1
debian/changelog
vendored
1
debian/changelog
vendored
|
@ -18,6 +18,7 @@ midori (0.5.2+dfsg-1) UNRELEASED; urgency=low
|
|||
[ Ryan Niebur ]
|
||||
* new upstream version, including the waf unpack changes made thanks
|
||||
to the NMU by Koichi Akabe
|
||||
- refreshed patches
|
||||
|
||||
-- Ryan Niebur <ryan@debian.org> Wed, 23 Oct 2013 20:46:22 -0700
|
||||
|
||||
|
|
17
debian/patches/add-debian-searches
vendored
17
debian/patches/add-debian-searches
vendored
|
@ -1,12 +1,11 @@
|
|||
diff --git a/data/search b/data/search
|
||||
index e759642..59341ee 100644
|
||||
--- a/data/search
|
||||
+++ b/data/search
|
||||
@@ -27,3 +27,17 @@ name=The Free Dictionary
|
||||
text=Dictionary, Encyclopedia and Thesaurus
|
||||
uri=http://www.thefreedictionary.com/%s
|
||||
token=fd
|
||||
+
|
||||
Index: midori/data/search
|
||||
===================================================================
|
||||
--- midori.orig/data/search 2013-10-23 20:45:02.000000000 -0700
|
||||
+++ midori/data/search 2013-10-23 20:47:57.000000000 -0700
|
||||
@@ -34,3 +34,16 @@
|
||||
uri=http://translate.google.com/?q=
|
||||
token=gt
|
||||
|
||||
+[Debian Packages]
|
||||
+name=Debian Packages
|
||||
+text=Search Debian Packages
|
||||
|
|
21
debian/patches/force-ssl-cert-verification.patch
vendored
21
debian/patches/force-ssl-cert-verification.patch
vendored
|
@ -1,8 +1,8 @@
|
|||
diff --git a/midori/main.c b/midori/main.c
|
||||
index 2ec5599..af3cc71 100644
|
||||
--- a/midori/main.c
|
||||
+++ b/midori/main.c
|
||||
@@ -1019,7 +1019,7 @@ midori_load_soup_session (gpointer settings)
|
||||
Index: midori/midori/midori-session.c
|
||||
===================================================================
|
||||
--- midori.orig/midori/midori-session.c 2013-10-23 20:49:21.000000000 -0700
|
||||
+++ midori/midori/midori-session.c 2013-10-23 20:49:48.000000000 -0700
|
||||
@@ -172,7 +172,7 @@
|
||||
#if defined (HAVE_LIBSOUP_2_37_1)
|
||||
g_object_set (session,
|
||||
"ssl-use-system-ca-file", TRUE,
|
||||
|
@ -11,7 +11,7 @@ index 2ec5599..af3cc71 100644
|
|||
NULL);
|
||||
#elif defined (HAVE_LIBSOUP_2_29_91)
|
||||
const gchar* certificate_files[] =
|
||||
@@ -1038,7 +1038,7 @@ midori_load_soup_session (gpointer settings)
|
||||
@@ -191,7 +191,7 @@
|
||||
{
|
||||
g_object_set (session,
|
||||
"ssl-ca-file", certificate_files[i],
|
||||
|
@ -20,3 +20,12 @@ index 2ec5599..af3cc71 100644
|
|||
NULL);
|
||||
break;
|
||||
}
|
||||
@@ -206,7 +206,7 @@
|
||||
gchar* certificate_file = midori_paths_get_res_filename ("ca-bundle.crt");
|
||||
g_object_set (session,
|
||||
"ssl-ca-file", certificate_file,
|
||||
- "ssl-strict", FALSE,
|
||||
+ "ssl-strict", TRUE,
|
||||
NULL);
|
||||
g_free (certificate_file);
|
||||
#endif
|
||||
|
|
Loading…
Reference in a new issue