* Non-maintainer upload.

* debian/patches:
  - 0001-Only-no-adblock-if-main-frame-in-provisional-state added, fix
    adblock extension.                                        closes: #611682
* debian/rules:
  - remove .lock-script in clean target.
This commit is contained in:
Yves-Alexis Perez 2011-02-02 13:10:36 +01:00
parent 82f583451c
commit 41bc26c145
4 changed files with 39 additions and 0 deletions

11
debian/changelog vendored
View file

@ -1,3 +1,14 @@
midori (0.3.0-1.2) unstable; urgency=low
* Non-maintainer upload.
* debian/patches:
- 0001-Only-no-adblock-if-main-frame-in-provisional-state added, fix
adblock extension. closes: #611682
* debian/rules:
- remove .lock-script in clean target.
-- Yves-Alexis Perez <corsac@debian.org> Wed, 02 Feb 2011 10:14:47 +0100
midori (0.3.0-1.1) unstable; urgency=low midori (0.3.0-1.1) unstable; urgency=low
* Non-maintainer upload. * Non-maintainer upload.

View file

@ -0,0 +1,26 @@
From 90e11d3713f68fece0b28cc2a1bda3dde8aa3303 Mon Sep 17 00:00:00 2001
From: Christian Dywan <christian@twotoasts.de>
Date: Tue, 1 Feb 2011 01:52:39 +0100
Subject: [PATCH] Only no adblock if main frame in provisional state
---
extensions/adblock.c | 3 ++-
1 files changed, 2 insertions(+), 1 deletions(-)
diff --git a/extensions/adblock.c b/extensions/adblock.c
index 6ae7adc..ff08b67 100644
--- a/extensions/adblock.c
+++ b/extensions/adblock.c
@@ -753,7 +753,8 @@ adblock_resource_request_starting_cb (WebKitWebView* web_view,
const char *page_uri;
/* Never filter the main page itself */
- if (web_frame == webkit_web_view_get_main_frame (web_view))
+ if (web_frame == webkit_web_view_get_main_frame (web_view)
+ && webkit_web_frame_get_load_status (web_frame) == WEBKIT_LOAD_PROVISIONAL)
return;
req_uri = webkit_network_request_get_uri (request);
--
1.7.2.3

View file

@ -1 +1,2 @@
add-debian-searches add-debian-searches
0001-Only-no-adblock-if-main-frame-in-provisional-state.patch

1
debian/rules vendored
View file

@ -41,6 +41,7 @@ override_dh_auto_clean:
$(WAF) --nocache distclean $(WAF) --nocache distclean
rm -rf _build_ rm -rf _build_
rm -rf .waf* rm -rf .waf*
rm -rf .lock-wscript
override_dh_auto_configure: override_dh_auto_configure:
$(WAF) --nocache configure --prefix /usr $(WAF) --nocache configure --prefix /usr