change the default-homepage patch to use the files in debian/config/ to set the default homepage based on whether it's debian, ubuntu, etc (second half of ubuntu diff)
This commit is contained in:
parent
4ab76d4a18
commit
eb943a778a
7 changed files with 23 additions and 3 deletions
5
debian/changelog
vendored
5
debian/changelog
vendored
|
@ -12,8 +12,11 @@ midori (0.1.7-1) UNRELEASED; urgency=low
|
||||||
patch (Closes: #525991)
|
patch (Closes: #525991)
|
||||||
* New Upstream Version
|
* New Upstream Version
|
||||||
* refresh patches
|
* refresh patches
|
||||||
|
* change the default-homepage patch to use the files in debian/config/
|
||||||
|
to set the default homepage based on whether it's debian, ubuntu,
|
||||||
|
etc (second half of ubuntu diff)
|
||||||
|
|
||||||
-- Ryan Niebur <ryanryan52@gmail.com> Thu, 28 May 2009 23:16:32 -0700
|
-- Ryan Niebur <ryanryan52@gmail.com> Thu, 28 May 2009 23:28:24 -0700
|
||||||
|
|
||||||
midori (0.1.6-1) experimental; urgency=low
|
midori (0.1.6-1) experimental; urgency=low
|
||||||
|
|
||||||
|
|
1
debian/clean
vendored
Normal file
1
debian/clean
vendored
Normal file
|
@ -0,0 +1 @@
|
||||||
|
midori/midori-debian.h
|
1
debian/config/Debian.h
vendored
Normal file
1
debian/config/Debian.h
vendored
Normal file
|
@ -0,0 +1 @@
|
||||||
|
#define DEBIAN_DISTRO_DEFAULT_HOMEPAGE "file:///usr/share/doc/midori/user/midori.html"
|
1
debian/config/Ubuntu.h
vendored
Normal file
1
debian/config/Ubuntu.h
vendored
Normal file
|
@ -0,0 +1 @@
|
||||||
|
#define DEBIAN_DISTRO_DEFAULT_HOMEPAGE "file:///usr/share/ubuntu-artwork/home/index.html"
|
1
debian/control
vendored
1
debian/control
vendored
|
@ -5,6 +5,7 @@ Maintainer: Ryan Niebur <ryanryan52@gmail.com>
|
||||||
Build-Depends:
|
Build-Depends:
|
||||||
debhelper (>= 7.0.50),
|
debhelper (>= 7.0.50),
|
||||||
quilt (>= 0.46-7),
|
quilt (>= 0.46-7),
|
||||||
|
lsb-release,
|
||||||
libgtk2.0-dev (>= 2.10),
|
libgtk2.0-dev (>= 2.10),
|
||||||
libglib2.0-dev,
|
libglib2.0-dev,
|
||||||
libwebkit-dev (>= 1.1),
|
libwebkit-dev (>= 1.1),
|
||||||
|
|
12
debian/patches/default-homepage
vendored
12
debian/patches/default-homepage
vendored
|
@ -9,12 +9,20 @@ Midori's user documentation. This is similar to what Dillo did/does.
|
||||||
|
|
||||||
--- a/midori/midori-websettings.c
|
--- a/midori/midori-websettings.c
|
||||||
+++ b/midori/midori-websettings.c
|
+++ b/midori/midori-websettings.c
|
||||||
@@ -558,7 +558,7 @@
|
@@ -10,6 +10,7 @@
|
||||||
|
*/
|
||||||
|
|
||||||
|
#include "midori-websettings.h"
|
||||||
|
+#include "midori-debian.h"
|
||||||
|
|
||||||
|
#include "sokoke.h"
|
||||||
|
|
||||||
|
@@ -558,7 +559,7 @@
|
||||||
"homepage",
|
"homepage",
|
||||||
_("Homepage"),
|
_("Homepage"),
|
||||||
_("The homepage"),
|
_("The homepage"),
|
||||||
- "http://www.google.com",
|
- "http://www.google.com",
|
||||||
+ "file:///usr/share/doc/midori/user/midori.html",
|
+ DEBIAN_DISTRO_DEFAULT_HOMEPAGE,
|
||||||
flags));
|
flags));
|
||||||
|
|
||||||
/**
|
/**
|
||||||
|
|
5
debian/rules
vendored
5
debian/rules
vendored
|
@ -3,6 +3,11 @@
|
||||||
%:
|
%:
|
||||||
dh --with quilt $@
|
dh --with quilt $@
|
||||||
|
|
||||||
|
override_dh_quilt_patch:
|
||||||
|
ln -sf ../debian/config/$(shell lsb_release -is).h midori/midori-debian.h
|
||||||
|
test -e midori/midori-debian.h
|
||||||
|
dh_quilt_patch
|
||||||
|
|
||||||
override_dh_auto_clean:
|
override_dh_auto_clean:
|
||||||
./waf --nocache distclean
|
./waf --nocache distclean
|
||||||
rm -rf _build_
|
rm -rf _build_
|
||||||
|
|
Loading…
Reference in a new issue