force-ssl-cert-verification added, set ssl-strict to TRUE so connections are not done if the ssl certificate can't be trusted.
This commit is contained in:
parent
fd5d3ee02c
commit
ee57ca1056
3 changed files with 25 additions and 0 deletions
2
debian/changelog
vendored
2
debian/changelog
vendored
|
@ -10,6 +10,8 @@ midori (0.4.5-1) UNRELEASED; urgency=low
|
|||
closes: #660303
|
||||
* debian/patches:
|
||||
- fix-libsoup detection added.
|
||||
- force-ssl-cert-verification added, set ssl-strict to TRUE so connections
|
||||
are not done if the ssl certificate can't be trusted.
|
||||
|
||||
-- Yves-Alexis Perez <corsac@debian.org> Sat, 14 Apr 2012 14:47:59 +0200
|
||||
|
||||
|
|
22
debian/patches/force-ssl-cert-verification.patch
vendored
Normal file
22
debian/patches/force-ssl-cert-verification.patch
vendored
Normal file
|
@ -0,0 +1,22 @@
|
|||
diff --git a/midori/main.c b/midori/main.c
|
||||
index 2ec5599..af3cc71 100644
|
||||
--- a/midori/main.c
|
||||
+++ b/midori/main.c
|
||||
@@ -1019,7 +1019,7 @@ midori_load_soup_session (gpointer settings)
|
||||
#if defined (HAVE_LIBSOUP_2_37_1)
|
||||
g_object_set (session,
|
||||
"ssl-use-system-ca-file", TRUE,
|
||||
- "ssl-strict", FALSE,
|
||||
+ "ssl-strict", TRUE,
|
||||
NULL);
|
||||
#elif defined (HAVE_LIBSOUP_2_29_91)
|
||||
const gchar* certificate_files[] =
|
||||
@@ -1038,7 +1038,7 @@ midori_load_soup_session (gpointer settings)
|
||||
{
|
||||
g_object_set (session,
|
||||
"ssl-ca-file", certificate_files[i],
|
||||
- "ssl-strict", FALSE,
|
||||
+ "ssl-strict", TRUE,
|
||||
NULL);
|
||||
break;
|
||||
}
|
1
debian/patches/series
vendored
1
debian/patches/series
vendored
|
@ -1,2 +1,3 @@
|
|||
add-debian-searches
|
||||
fix-libsoup-detect.patch
|
||||
force-ssl-cert-verification.patch
|
||||
|
|
Loading…
Reference in a new issue